Email Server Delays
Incident Report for CIT Geneseo Status
Resolved
We have resolved the problem with mail server. The mail queue is processing now, and queued messages should be delivered before noon.
Posted Feb 17, 2020 - 09:58 EST
Identified
Our email server queue is significantly backed up due to attackers trying to guess users' passwords. Messages sent through our campus mail server will be delayed, including scans from Toshiba devices sent to email. We're working on mitigating these attacks and clearing the queue backlog.
Posted Feb 17, 2020 - 09:26 EST