Banner Admin Forms (Banner9) connection issues
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Sep 12, 2019 - 17:32 EDT
Investigating
We are experiencing Banner Admin Forms (Banner9) connection issues. If you are currently connected to Banner, please remain connected. We will restart Banner9 services at approximately 5pm to resolve the issue.
Posted Sep 12, 2019 - 15:12 EDT
This incident affected: Administrative Systems (Banner).