Campus Print Server Slowness
Incident Report for CIT Geneseo Status
Resolved
After clearing several queues clogged up with old jobs, printing services are again responding normally.
Posted May 09, 2022 - 12:48 EDT
Investigating
We have received reports that the campus print server is slow in response to requests. We are investigating the problem now.
Posted May 09, 2022 - 11:52 EDT
This incident affected: Campus Services (Printing (Pharos Cloud)).