www.geneseo.edu website experiencing intermittent page failures
Incident Report for CIT Geneseo Status
Resolved
This incident is resolved and we are continuing to monitor the situation
Posted Dec 03, 2022 - 08:02 EST
Monitoring
The problem appears to have resolved itself but we are still investigating the cause.
Posted Dec 03, 2022 - 07:34 EST
Investigating
The www.geneseo.edu website is experiencing intermittent page failures. The site is displaying the message "The website encountered an unexpected error. Please try again later."

We are investigating the cause of the problem
Posted Dec 03, 2022 - 07:01 EST
This incident affected: Web (Geneseo Website).