The scheduled upgrade of Appworx is complete. In order to access the system you will need to download the new version of the client from http://genban281.itec.suny.edu:5050/APWXPROD/Intro.html and install it. Installation instructions are available here. If you have any issues installing it, please contact CIT via the helpdesk We will be monitoring the system as closely as possible for any issues. Please check any output closely and let CIT know, via the helpdesk, of any issues in your jobs or reports.
Posted Aug 09, 2025 - 10:42 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 08, 2025 - 19:00 EDT
Scheduled
This weekend we are planning to upgrade our Appworx environment to the latest version.
The work should only take Friday evening, but we are allowing the time of the full weekend in case of complications.
This will require you to re-download the Appworx client after the upgrade is complete, We will provide additional information on this when the process is complete.
Posted Aug 07, 2025 - 09:08 EDT
This scheduled maintenance affected: Administrative Systems (AppWorx).