Telephone Call Outage
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted May 24, 2019 - 07:44 EDT
Update
We are again suffering inconsistent in and outbound call behavior - our phone company is aware and they are working on it.
Posted May 23, 2019 - 10:56 EDT
Monitoring
Calls are again properly passing to and from campus.

Our provider was short on details but they did note that there was a circuit issue between their network and the campus.

We are still monitoring the issue.
Posted May 23, 2019 - 08:33 EDT
Investigating
Normal telephone calls are not properly coming into and leaving campus. We are researching the problem now.
Posted May 23, 2019 - 08:27 EDT
This incident affected: Campus Services (Telephone Services).