Knightweb is available - the servers have been restarted.
Incident Report for CIT Geneseo
Resolved
This incident has been resolved.
Posted Apr 02, 2020 - 04:53 EDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2020 - 22:25 EDT
This incident affected: Academic Services (KnightWeb).