Spring 2020 Printing Credits Not Applied
Incident Report for CIT Geneseo Status
Resolved
Spring 2020 printer accounting credits have now been applied. If you still notice any issue with your balance, please let us know.
Posted Jan 22, 2020 - 15:54 EST
Investigating
There was an issue with the process that applies printing credits for the Spring semester. We are looking into the problem now, and credits should be applied later this afternoon.
Posted Jan 22, 2020 - 12:19 EST
This incident affected: Campus Services (Printing (Pharos Cloud)).