Knightweb Single Sign-On Not Working
Incident Report for CIT Geneseo Status
Resolved
KnightWeb is now available. We apologize for the unexpected downtime.
Posted Feb 12, 2020 - 11:16 EST
Investigating
The knightweb single sign-on service is currently not working. We are investigating the issue now.
Posted Feb 12, 2020 - 10:55 EST
This incident affected: Academic Services (KnightWeb).