JIRA (help.geneseo.edu) Slow
Incident Report for SUNY Geneseo
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 12, 2018 - 09:42 EST
Identified
JIRA is performing very slowly. We are restarting the service to alleviate the issue.
Posted 6 months ago. Jan 12, 2018 - 09:34 EST
This incident affected: Campus Services (help.geneseo.edu (JIRA)).