Multiple server outage

Incident Report for CIT Geneseo Status

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 13:41 EDT

Monitoring

We have identified and resolved the storage issue that caused the outage on campus. Services have been restored and we are monitoring affected systems.
Posted Oct 11, 2025 - 08:23 EDT

Investigating

We have received reports that many servers on campus are not responding. We are investigating the issue now.
Posted Oct 11, 2025 - 07:30 EDT
This incident affected: Campus Services (SAN (Storage Area Network), VMWare Infrastructure).