DegreeWorks Service Unavailable
Incident Report for CIT Geneseo
Resolved
The issue has been resolved and the DegreeWorks service is now available.
Posted 2 months ago. Mar 13, 2019 - 09:29 EDT
Investigating
The DegreeWorks service is currently unavailable. Our SUNY hosting partner is working on resolving the problem now.
Posted 2 months ago. Mar 13, 2019 - 08:18 EDT
This incident affected: Academic Services (Degree Works).