Damage to Underground Telephone Cable Serving Original "North Quad" Buildings
Incident Report for CIT Geneseo Status
Resolved
Repairs to this cable are complete.
Posted Apr 16, 2018 - 15:01 EDT
Update
We have clearly identified that many of the phone lines inside the cable are damaged beyond repair. We are beginning to research repair options.
Posted Dec 04, 2017 - 14:15 EST
Identified
Contractors working on the underground infrastructure project in the Sturges quad have damaged the cable that provides traditional voice telephone service to analog devices in Allegany, Wyoming, Genesee, Ontario, Erie, and Letchworth. This may be impacting fax lines, ATMs, gas meters, and emergency phones. We are still investigating to understand the full impact of the damage. VoIP telephones are not impacted by this issue.
Posted Dec 04, 2017 - 10:40 EST
This incident affected: Campus Services (Telephone Services).