Network Outage in Newton Lecture Halls
Incident Report for CIT Geneseo Status
Resolved
A failed battery backup unit caused a power outage to the network switch. Power has been restored and all services are now operational.
Posted Sep 22, 2021 - 09:20 EDT
Investigating
We have a network switch down in Newton causing a wireless outage in some of the lecture halls. We are investigating now.
Posted Sep 22, 2021 - 09:00 EDT
This incident affected: Network & Wireless (Wireless Connectivity).