SUNY Single Sign-on Not Working - Degreeworks and other applications impacted
Incident Report for CIT Geneseo Status
Resolved
The SUNY Single Sign-On service has been restored and all SUNY hosted services, including DegreeWorks, should be available again.
Posted Oct 19, 2020 - 10:48 EDT
Update
SUNY is continuing to investigate the Single Sign-On outage impacting all SUNY services including DegreeWorks. We do not have any new information at this time. We will publish an update at 11am unless new information is made available sooner.
Posted Oct 19, 2020 - 10:03 EDT
Investigating
The SUNY Federated Single Sign-on system is currently not working. This impacts multiple SUNY applications including DegreeWorks, SUNY self-service portal, and others. SUNY is currently investigating
Posted Oct 19, 2020 - 08:29 EDT
This incident affected: Academic Services (Degree Works).