DegreeWorks Service Unavailable again
Incident Report for CIT Geneseo Status
Resolved
We have received notice from ITEC that the DegreeWorks issues have been resolved.
Posted Jul 18, 2018 - 12:10 EDT
Monitoring
We have not received an official notice from the SUNY hosting team, but the DegreeWorks service does appear to be operational at this point.
Posted Jul 18, 2018 - 11:03 EDT
Investigating
The DegreeWorks service is unavailable again. The SUNY hosting team is working on restoring it. They currently are estimating it will be available by 10am.
Posted Jul 18, 2018 - 09:44 EDT
This incident affected: Academic Services (Degree Works).