Banner Admin Pages connection issues
Incident Report for CIT Geneseo Status
Resolved
All servers in the pool for Banner Admin Pages are now responsive
Posted Jan 19, 2022 - 07:56 EST
Investigating
We are currently investigating Banner Admin Pages connection issues
Posted Jan 19, 2022 - 07:44 EST
This incident affected: Administrative Systems (Banner).