Login to many Service not working
Incident Report for CIT Geneseo Status
Resolved
We have resolved the issue and all services should now be operational again.
Posted Oct 07, 2018 - 13:45 EDT
Update
We are continuing to attempt to resolve the issue with SSO. We will update again by 2pm.
Posted Oct 07, 2018 - 13:04 EDT
Update
We have resolved the expired certificate error. However, single sign on (SSO) is still not working. We are continuing to work on the issue.

Services relying solely on connections to adlb.geneseo.edu are now working. We will update again by 1pm.
Posted Oct 07, 2018 - 12:16 EDT
Update
We have discovered the cause of the issue. A certificate has expired for the secure load balanced active directory connection. We are working to remedy as soon as possible. We will update again by 12:15.
Posted Oct 07, 2018 - 11:46 EDT
Identified
We believe we have identified the issue. It is impacting any service using adlb.geneseo.edu to talk to active directory. We are attempting a fix to resolve the connection issues to adlb.geneseo.edu. We will update again by 11:45.
Posted Oct 07, 2018 - 11:15 EDT
Investigating
We have received reports that logins through our single sign on (SSO) service (auth.geneseo.edu) is not working. We are investigating this issue now. Users are receiving invalid credentials errors despite entering correct credentials.
Posted Oct 07, 2018 - 10:41 EDT
This incident affected: Web (Geneseo Website, MyGeneseo, Wordpress (wp.geneseo.edu)), Login Services (CAS Server, Active Directory), Academic Services (Degree Works, Geneseo Mobile, KnightWeb), and Administrative Systems (Argos, Banner).