Central Auth Errors
Incident Report for CIT Geneseo Status
Resolved
We believe we've identified and resolved the cause of the Central Auth errors. Users still experiencing errors should try going to https://my.geneseo.edu/logout or relaunching their web browser.
Posted May 13, 2021 - 10:16 EDT
Investigating
Some users are receiving Central Auth errors, most frequently when trying to access myGeneseo. The errors usually say "CAS Authentication Failed". We believe we understand what's causing these but don't yet know how best to fix them.
Posted May 13, 2021 - 09:03 EDT
This incident affected: Login Services (CAS Server) and Web (MyGeneseo).