EMS Desktop Client Applications is unavailable.
Incident Report for CIT Geneseo Status
Resolved
The EMS Desktop Client is working and available through the new EMS Desktop Client Deploy App.
Posted Aug 21, 2020 - 11:58 EDT
Investigating
We are currently investigating this issue.
Posted Jul 27, 2020 - 07:42 EDT