Canvas Speedgrader Issues
Incident Report for CIT Geneseo Status
Resolved
The Canvas Speedgrader issues are now resolved.
Posted May 16, 2022 - 14:09 EDT
Identified
Many faculty have reported issues grading this morning. DocViewer and Speedgrader are currently experiencing degraded performance in Canvas. Canvas is actively working on the issue, and we will update the status when it is resolved.

For more information visit status.Instructure.com
Posted May 16, 2022 - 12:27 EDT