Fraser Classroom Technology - Power Issues
Incident Report for CIT Geneseo Status
Resolved
We have heard of no further power issues in Fraser.
Posted Sep 05, 2018 - 15:59 EDT
Monitoring
The power in Fraser has been somewhat erratic this morning. Classroom technology is impacted. Facilities and CIT are monitoring the situation. Please contact the CIT HelpDesk at 585-245-5588 if you have any questions.
Posted Sep 05, 2018 - 11:26 EDT