Banner connection issues
Incident Report for CIT Geneseo Status
Resolved
Banner connection issues have been resolved
Posted Sep 30, 2019 - 10:19 EDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2019 - 10:14 EDT
Investigating
We are currently having problems connecting to Banner Admin Pages. We are investigating. If you are connected to Banner Admin Pages, do not log out.
Posted Sep 30, 2019 - 10:14 EDT
This incident affected: Administrative Systems (Banner).