Banner Admin Pages intermittent connection issues
Incident Report for CIT Geneseo Status
Resolved
To resolve the issue, services have been restarted on one of the Banner Admin Pages servers
Posted Jun 15, 2021 - 09:44 EDT
Investigating
We are currently investigating intermittent Banner Admin Pages connection issues.
Posted Jun 15, 2021 - 09:31 EDT
This incident affected: Administrative Systems (Banner).