Papercut Outage
Incident Report for CIT Geneseo Status
Resolved
Papercut has been restored to service.
Posted Feb 08, 2018 - 09:10 EST
Investigating
Papercut appears to be down due to a problem talking to its database.
Posted Feb 08, 2018 - 08:50 EST
This incident affected: Campus Services (Printing (Pharos Cloud)).