Xtender unavailable
Incident Report for SUNY Geneseo
Resolved
Xtender is now available
Posted 6 months ago. Jan 11, 2018 - 09:33 EST
Investigating
Xtender is unavailable. We are investigating.
Posted 6 months ago. Jan 11, 2018 - 07:52 EST
This incident affected: Administrative Systems (Xtender - Banner Document Management System).