my.geneseo.edu and www directory page are not working
Incident Report for CIT Geneseo Status
Resolved
The issue has been resolved and all the impacted web services should be working properly now. This minimally included my.geneseo.edu, www directory page, Slate CRM, SUNY services, library database pages, and other services that use SAML Single sign-on.

We are sorry for any impacts this caused you.
Posted May 30, 2020 - 12:00 EDT
Update
The problem is also impacting any services that relies on Geneseo's SimpleSAML single sign-on which includes the Slate CRM, SUNY services, and others. The root cause appears to be a problem with an encryption certificate for the Active Directory service. We are working to try to resolve the problem.
Posted May 30, 2020 - 10:55 EDT
Investigating
The my.geneseo.edu and www directory services are not working. It is possible other web services are impacted as well as the error appears related to directory services.
Posted May 30, 2020 - 10:17 EDT
This incident affected: Web (Geneseo Website, MyGeneseo) and Login Services (SUNY Portal).