PointNClick Electronic Medical Records System Outage
Incident Report for CIT Geneseo Status
Resolved
The certificate issue has been resolved and myhealth.geneseo.edu/healthapp.geneseo.edu are working properly again now.
Posted May 11, 2022 - 08:08 EDT
Investigating
We have received reports of a certificate error with myhealth.geneseo.edu. We are looking into the problem now.
Posted May 11, 2022 - 07:48 EDT
This incident affected: Administrative Systems (PointNClick Electronic Medical Records).