The Appworx client is down
Incident Report for CIT Geneseo Status
Resolved
Appworx has been restarted and is available.
Posted Sep 06, 2019 - 13:35 EDT
Investigating
We are currently investigating this issue.
Posted Sep 06, 2019 - 13:29 EDT
This incident affected: Administrative Systems (AppWorx).