Appworx is Down
Incident Report for CIT Geneseo Status
Resolved
Appworx is back available.
Posted Aug 10, 2018 - 15:53 EDT
Investigating
Appworx is not available. We are investigating.
Posted Aug 10, 2018 - 14:04 EDT
This incident affected: Administrative Systems (AppWorx).