Group Menu and Group Module Update
Incident Report for CIT Geneseo Status
Resolved
We are continuing to investigate this issue.
Posted Nov 23, 2019 - 09:06 EST
Update
We are continuing to investigate this issue.
Posted Nov 23, 2019 - 09:05 EST
Investigating
The group menu and group modules will be undergoing upgrades on the site. Down time may occur during upgrade.
Posted Nov 23, 2019 - 05:00 EST
This incident affected: Web (Geneseo Website).