Network Outage in ISC
Incident Report for CIT Geneseo
Resolved
A power issue caused the network to restart on the second floor of the ISC. Services have returned to normal.
Posted 18 days ago. Mar 01, 2019 - 08:56 EST
Investigating
We have just become aware of a network outage in the ISC. We are investigating now.
Posted 19 days ago. Mar 01, 2019 - 08:27 EST
This incident affected: Network & Wireless (Wireless Connectivity, Academic/Administrative Wired Connectivity).