Xtender connection issues
Incident Report for CIT Geneseo Status
Resolved
The Xtender issue has been resolved by updating a security certificate. Please contact the CIT Help Desk if you continue to experience issues.
Posted Oct 15, 2021 - 09:33 EDT
Investigating
We are currently investigating Xtender connection issues.
Posted Oct 15, 2021 - 09:13 EDT
This incident affected: Administrative Systems (Xtender - Banner Document Management System).