The rollback has been completed and PowerApps services have been restored. We have verified the permissions prompt for the Faculty Activity Summaries is again displaying properly.
Posted Apr 28, 2026 - 06:53 EDT
Identified
Microsoft has initiated the deployment of the fix to rollback to a previous version after identifying that as the most safe and effective change. They have further confirmed, after investigating the impacting change, that it introduced a regression into the web player client code, resulting in errors being returned from the Consent API.
Microsoft estimates that this issue will resolve with the completion of the reversion deployment in three hours. They will update us again by 7:30pm with a new status.
Posted Apr 27, 2026 - 15:26 EDT
Investigating
Faculty attempting to add a new item to the Faculty Activity Summaries for the first time are experiencing a looping refresh connection prompt that never successfully completes. This will also affect any other PowerApps forms on campus. The outage is due to a global Microsoft issue caused by a recent change to the method in how secure connection requests are processed in the Consent API. Microsoft engineers are working on a solution. We will update this outage by 4pm with any new information.
Posted Apr 27, 2026 - 15:02 EDT
This incident affected: Campus Services (Microsoft Updates).