Docuware is unavailable
Incident Report for CIT Geneseo Status
Resolved
The Docuware database is now available.
Posted Sep 03, 2024 - 11:12 EDT
Investigating
We are investigating an issue with the Docuware database. Docuware is currently unavailable.
Posted Sep 03, 2024 - 10:10 EDT
This incident affected: Administrative Systems (Docuware).