Login Errors Reported for Geneseo Services

Incident Report for CIT Geneseo Status

Resolved

We have replaced the certificate and services have returned to normal.
Posted Oct 06, 2020 - 20:51 EDT

Identified

We have identified an issue with an expired certificate causing logins to many services to fail. We are replacing the certificate and expect to have services restored soon.
Posted Oct 06, 2020 - 20:45 EDT

Investigating

We are investigating reports of login errors for Geneseo services (including myGeneseo).
Posted Oct 06, 2020 - 20:38 EDT