Pharos Outage

Incident Report for CIT Geneseo Status

Resolved

Pharos reports that the problem has been identified and mitigated.
Posted Mar 23, 2026 - 11:49 EDT

Monitoring

Secure Print services have recovered. We are continuing to monitor the platform.
Posted Mar 23, 2026 - 10:53 EDT

Investigating

Pharos has reported a problem preventing user sign-ins as well as release of Secure Print jobs. The issue is currently under investigation. This situation can be monitored at https://status.pharos.com.
Posted Mar 23, 2026 - 10:23 EDT
This incident affected: CIT Announcement.