Docuware unavailable
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 07:18 EDT
Identified
The problem with the database has been identified and we are working on a solution.
Posted Oct 09, 2024 - 12:30 EDT
Investigating
Docuware is unavailable. We are investigating.
Posted Oct 09, 2024 - 11:55 EDT
This incident affected: Administrative Systems (Docuware).