AWS (Amazon Web Services) Global Outage

Incident Report for CIT Geneseo Status

Resolved

Amazon has resolved their infrastructure issue, and our vendors have reported services have returned to normal. Please let us know if you notice any lingering problems as a result of the outage at https://help.geneseo.edu/cit
Posted Oct 21, 2025 - 06:42 EDT

Update

As the AWS outage continues, we are discovering more affected systems.
Brightspace - general slowness, assignment submission errors, document previews not loading, issues accessing course content
Navigate - slowness, search errors
CIT Self Help (Atlassian Confluence) - search errors, page loading errors
Posted Oct 20, 2025 - 13:39 EDT

Identified

Amazon Web Services, which provide infrastructure for many services, are currently recovering from a global outage (https://health.aws.amazon.com/health/status) that affected a large number of applications and services.

Most systems have started to recover, but Adobe and Atlassian Jira are still experiencing effects.
https://status.adobe.com/
https://status.atlassian.com/

We will update as we receive new information.
Posted Oct 20, 2025 - 08:15 EDT
This incident affected: Campus Services (help.geneseo.edu (JIRA)) and Administrative Systems (Adobe Acrobat Sign).