VPN maintenance is complete. Geneseo VPN users should be prompted to update to the new version on their next launch of the VPN client. Mac users need to elevate with Privileges before installing this update.
Posted Oct 13, 2025 - 10:25 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 13, 2025 - 08:00 EDT
Scheduled
We're going to update our VPN server at 8am on Monday, October 13th. VPN users will be prompted to update their client during their next connection after the server update. Windows users should be able to apply the update without admin rights; Mac users of college-owned devices will need to elevate with Privileges before installing the update. Beyond security patches, this update adds support for macOS Tahoe and running natively on Apple Silicon.
Posted Sep 29, 2025 - 14:09 EDT
This scheduled maintenance affected: Network & Wireless (VPN).