HelpDesk Phone Outage

Incident Report for CIT Geneseo Status

Resolved

We have resolved the issues with incoming helpdesk calls.
Posted Aug 24, 2025 - 11:05 EDT

Investigating

We’re currently experiencing an issue receiving external calls to the CIT HelpDesk phone line. Our team is actively working to resolve the issue.

In the meantime, please submit all support requests through the CIT Service Desk at https://geneseo.atlassian.net/servicedesk/customer/portal/12.

We apologize for the inconvenience and appreciate your patience!
Posted Aug 23, 2025 - 12:49 EDT
This incident affected: Campus Services (Telephone Services).