CRM Advance unavailable due to CrowdStrike security software outage
Incident Report for CIT Geneseo Status
Resolved
CRM Advance appears to be working now. Please contact the CIT Helpdesk if you encounter any issues.
Posted Jul 19, 2024 - 14:59 EDT
Update
Update from Ellucian:
We are continuing to make progress. Some major services are now fully restored. We will keep posting updates as we have them.
Posted Jul 19, 2024 - 12:52 EDT
Update
Ellucian continues to work on the outage
Posted Jul 19, 2024 - 10:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 08:55 EDT
Investigating
CRM Advance, cloud hosted at Ellucian, is unavailable due to the widespread CrowdStrike outage.
Posted Jul 19, 2024 - 08:55 EDT
This incident affected: Campus Services (General Announcement).