Pharos Print Service Outage

Incident Report for CIT Geneseo Status

Resolved

The issue impacting Pharos Print services has been resolved. Please ask CIT for assistance if you are still encountering any errors.
Posted Oct 30, 2025 - 08:28 EDT

Monitoring

Pharos Print Services are available again, and CIT is currently monitoring the situation.
Posted Oct 29, 2025 - 09:48 EDT

Investigating

We are currently experiencing a print service disruption.

Our CIT team is working to identify the root cause and implement a solution. All Pharos services are currently impacted.
Posted Oct 29, 2025 - 09:14 EDT
This incident affected: Campus Services (Printing (Pharos Cloud)).