SMTP Problems Generating Unexpected Bounces
Incident Report for CIT Geneseo Status
Resolved
We think we have resolved the issue with email bounces. If you received a bounce to a geneseo.edu recipient today, please retry your message.
Posted Nov 08, 2024 - 13:42 EST
Investigating
We're investigating reports of bounces being generated in response to messages sent to active accounts. If you receive a bounce in response to a message, please wait until we resolve this incident before trying to send your message again.
Posted Nov 08, 2024 - 13:08 EST