Argos Unavailable
Incident Report for CIT Geneseo Status
Resolved
Argos is operating normally now. There was a problem with a conflicting IP address for the server that caused problems.
Posted Oct 04, 2024 - 13:22 EDT
Investigating
Argos is currently having connection problems. We're looking into the issue.
Posted Oct 04, 2024 - 12:46 EDT
This incident affected: Administrative Systems (Argos).