Banner Admin Pages Not Loading for some users
Incident Report for CIT Geneseo Status
Resolved
This incident has been resolved.
Posted May 01, 2020 - 12:25 EDT
Investigating
We have reports from some users that Banner Admin Pages on banner.geneseo.edu are not loading. They are seeing timeouts. We are currently investigating the problem.
Posted May 01, 2020 - 12:17 EDT
This incident affected: Administrative Systems (Banner).