Degree Works, Brightspace, SUNY HR, KnightSource SSO connection issues

Incident Report for CIT Geneseo Status

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 08:35 EDT

Monitoring

A fix has been implemented. We will continue to monitor.
Posted Jul 23, 2026 - 08:20 EDT

Update

EVERY service behind SUNY central SSO is going to be affected (Degree Works, Brightspace, SUNY HR, KnightSource, etc.)
Posted Jul 23, 2026 - 07:52 EDT

Investigating

We are investigating issues connecting to Degree Works.
Posted Jul 23, 2026 - 07:33 EDT
This incident affected: Academic Services (Brightspace, Degree Works) and Login Services (SUNY Portal).