Google Rejecting Small Subset of Email
Incident Report for CIT Geneseo Status
Resolved
We have not seen any additional errors or warnings from Google in our smtp mail logs; the problem appears to be fixed.
Posted Mar 21, 2024 - 08:14 EDT
Monitoring
We have implemented the new requirement Google communicated in recent mail server conversations. We'll continue to monitor over the next 24 hours to see if we see the return of these mail failures.
Posted Mar 20, 2024 - 15:49 EDT
Identified
Some mail that is sent through our campus mail server is being either rejected or throttled by Google; we're investigating. Mail sent via Gmail (both apps and web) are unaffected.
Posted Mar 20, 2024 - 15:32 EDT