Network/Internet Outage
Incident Report for CIT Geneseo Status
Resolved
A configuration issue on our firewall has been identified and resolved, all network connectivity has returned to normal.
Posted Mar 20, 2024 - 11:50 EDT
Investigating
We have received reports of a widespread network/Internet outage that appears to have resolved itself. We are investigating the cause now.
Posted Mar 20, 2024 - 11:10 EDT
This incident affected: Network & Wireless (Wireless Connectivity, Academic/Administrative Wired Connectivity, Internet Connectivity).