College Website Unavailable

Incident Report for CIT Geneseo Status

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 15:59 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 14, 2025 - 10:56 EST

Monitoring

We identified a problem with our load balancing software and have implemented a fix.

The College website is now operational.

We will continue to monitor.
Posted Feb 14, 2025 - 10:51 EST

Investigating

The college website is currently not available. We're working to restore service.
Posted Feb 14, 2025 - 10:29 EST
This incident affected: Web (Geneseo Website).